
http://www.tutorialspoint.com Copyright © tutorialspoint.com

QTP MOCK TESTQTP MOCK TEST

This section presents you various set of Mock Tests related to QTP Framework. You can download
these sample mock tests at your local machine and solve offline at your convenience. Every mock
test is supplied with a mock test key to let you verify the final score and grade yourself.

QTP MOCK TEST IQTP MOCK TEST I

Q 1 - When you create a bitmap checkpoint, UFT captures only the visible part of the
object as bitmap, it does not capture anything which is scrolled off the screen.

A True

B False

Q 2 - An action cannot be splitted when :

1. An external action is selected.

2. The first step of an action is selected

3. A reusable action is selected

4. Recording a test

A - 1 only

B - 2 and 3 Only

C - 1 2 and 4 Only

D - All the Above

Q 3 - How do you Interrupt/Pause a running session ?

1. Automation > Pause.

2. Run > Pause

3. Tools > Pause

4. Clicking on Pause button at toolbar

5. Pressing Pause Keyboard button
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A - 1 only

B - 2 Only

C - 2 4 and 5 Only

D - 2 and 4 only

Q 4 - You can remove the call to an action from a test by selecting the action using

1. Resource pane

2. Test Flow pane

3. Keyword view

4. Expert view

A - 1 and 3 only

B - 2 and 4 Only

C - 1 2 and 3 Only

D - 3 and 4 only

Q 5 - Which of the tools is/are available along with the installation of UFT?

1. Silent Test Runner

2. Test Batch Runner

3. Script Batch Runner

4. Test Result Creation Tool

5. HP Video Player

6. Remote Agent

A - 1 2 and 3 only

B - 4 5 and 6 Only

C - 1 4 and 5 Only

D - 1 2 and 6 only

Q 6 - When you call a sub procedure, you can use the call statement as

1. call mySubProcargument

2. Also,you can omit the call statement and just use − mySubProcargument

A - True

B - False

Q 7 - Can you enhance your test by parameterizing the values used. Which of the
following are valid parameter type and can be used in your test?



1. Test/Action parameters

2. Data table parameters

3. Environment variable parameter

4. Recovery Parameters

5. Resources parameters

A - 1 and 3 only

B - 2 and 4 Only

C - 1 2 and 3 Only

D - 3 and 4 only

Q 8 - How do you call a function created within your test?

Function Flight(x)
 .. ... ...       
End Function      

1. Call Flight z

2. Call Flightz

3. n = Flightz

4. n = Flight z

A - 1 2 and 4 only

B - 2 and 3 only

C - 1 and 4 only

D - All 1 2 3 and 4

Q 9 - What information is displayed at System Monitor Tab in test result ?

1. Application Name, Counter scale, Current Step

2. Application Name, Product Name, System Information

3. System Counter List, Maximum Counter Value

4. System Information, Application Name and System Counter List

A - 1 and 3 only

B - 2 and 4 Only

C - 3 Only

D - 4 only

Q 10 - While merging two object repositories using Merge Tool, if an object in the
secondary repository has the same name, description properties and values as an
object in the primary object repository which has some additional properties and
values, how this conflict can be handled?



1. By keeping the object added from the primary object repository only.

2. By keeping the object added from secondary repository only.

3. By keeping the object added from both the repository.

4. by ignoring both repository and adding a fresh new object.

A - 1 2 and 3 only

B - 2 and 4 Only

C - 2 and 3 Only

D - 3 and 4 only

Q 11 - How can you can hide Item column in keyword view?

1. Right click on column header and unselect item

2. Right click select 'view options' and remove item from visible column list

3. Select Item column at Tools > View Options

4. you cannot hide Item column in keyword view

A - 1 and 3 only

B - 1 and 2 Only

C - 1 2 and 3 Only

D - 4 only

Q 12 - Steps recorded using Analog recording can be editable in keyword view.

A - True

B - False

Q 13 - Mark all the ways that can be used to share values between actions.

1. using Global Data Table

2. using Environment Variables

3. using sendparameter command

4. using Dictionary Objects

A - 1 and 2 only

B - 1 2 and 4 Only

C - 1 2 and 3 Only

D - All 1 2 3 and 4

Q 14 - Which of these checkpoints does not require the test to be in recording mode?.

1. Standard checkpoint



2. Database checkpoint

3. XML checkpoint

4. Page checkpoint

5. Bitmap Checkpoint

A - 1 and 2 only

B - 1 2 and 4 Only

C - 2 and 3 Only

D - All 1 2 3 and 4

Q 15 - Which of the following statement can be used if you want a run session to wait
until the a webedit field is enabled?.

1. Browser " Browser " .Page " Page " .WebEdit " Edit " .WaitProperty " disabled " , 0

2. Browser " Browser " .Page " Page " .WebEdit " Edit " .WaitProperty " disabled " , 1

3. Browser " Browser " .Page " Page " .WebEdit " Edit " .WaitProperty " enabled " , 1

4. Browser " Browser " .Page " Page " .WebEdit " Edit " .Enabled = True

5. Browser " Browser " .Page " Page " .WebEdit " Edit " .Enabled5

6. Browser " Browser " .Page " Page " .WebEdit " Edit " .Enabled = True

A - 1 and 3 only

B - 1 3 and 5 Only

C - 2 4 and 6 Only

D - 1 2 4 and 6

Q 16 - How can you open a process that is available for currently open document?

1. File > Process Guidance Management

2. Automation > Process Guidance List

3. Process Guidance Pane

4. we cannot open a process.

A - 1 and 3 only

B - 2 and 4 Only

C - 2 and 3 Only

D - 1 and 4 only

Q 17 - There is no need to specify HP ALM / QC in the list of browser to ignore at
Record and Run settings dialog box..

A - False



B - True

Q 18 - What type of image format UFT supports for CaptureBitmap method?

1. bmp

2. jpg

3. png

4. gif

A - 1 and 2 only

B - 1 2 and 4 Only

C - 1 and 3 Only

D - All 1 2 3 and 4

Q 19 - You can modify the concurrent license server.

1. using License Wizard

2. by setting LSHOST user variable

3. by setting LSFORCEHOST user variable

4. at Help > About dialog box

A - 1 and 2 only

B - 1 2 and 4 Only

C - 1 2 and 3 Only

D - All 1 2 3 and 4

Q 20 - UFT license type that is specific to a computer on which it is installed is known
as ________

1. Concurrent license

2. Floating license

3. Seat License

4. Personal License

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 21 - You can copy and paste OR drag-drop steps to move the steps to a different
location in Keyword view.

A - True



B - False

Q 22 - Recovery Scenarios, Object Repository per Action and Shared Object Repository
carry extensions

A - qrs, mtr and mtb respectively

B - qrs, mtr and tsr respectively

C - qrs, mtb and mts respectively

D - qrs, mst and mts respectively

Q 23 - Which of the following statements is/are false ?

1. UFT is an object based testing tool.

2. UFT is a Protocol based testing tool.

3. UFT is a Functional and Regression testing tool.

4. UFT is an open source testing tool.

A - 1 2 and 3 only

B - 1 and 3 Only

C - 2 and 4 Only

D - All 1 2 3 and 4

Q 24 - Using 'Save Test with resources', UFT saves a copy of any external action used.

A - False

B - True

Q 25 - Which of the following could be possible objectives for test automation? Mark
all that apply.

1. Increase speed of testing

2. Reduce manual effort

3. Ensure consistency

4. Eliminate manual testing.

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 26 - Which property/method can be used as custom checkpoints in UFT?



1. Wait

2. Exist

3. Sync

4. GetROProperty

A - 1 2 and 3 only

B - 1 2 and 4 Only

C - 1 and3 Only

D - 2 and 3

Q 27 - What can be used to capture timings in your test?

1. StartTransaction and EndTransaction

2. StartTime and EndTime

3. Timer

4. Sync

A - 1 2 and 3 only

B - 3 and 4 Only

C - 1 and 3 Only

D - 2 and 4

Q 28 - Which of the following is a recovery operation available in UFT?

1. Click Button with label

2. Click Link with Text

3. Click Default Button/Press the Enter Key

4. Click Cancel Button/Press the Enter Key

5. Mouse Left/Right Click

6. Press Key or Key Combination

A - 1 2 and 6 only

B - 1 and 3 Only

C - 1 2 and 3 Only

D - 3 4 and 5 Only

Q 29 - While creating a database checkpoint, you can define your database query
________

1. Using Connectionstring

2. Using Microsoft Query



3. Using Microsoft Debugger

4. By Manually defining a SQL Statement

A - 2 and 4 only

B - 3 Only

C - 1 and3 Only

D - 2 and 3

Q 30 - 'Exit For' can be used as an alternate way to exit from the loop of _______________.

1. Do...While

2. For...Loop

3. For...Next

4. For Each...Next

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D -3 and 4 only

Q 31 - Why do you use Add-in Manager?

1. to open UFT.

2. to load objects and properties for testing your application

3. to load support for testing your application.

4. to create object repository for testing your application

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 32 - Which function can be used to convert data from one subtype to another?

1. Date

2. Format

3. CInt

4. CStr

A - 2 3 and 4 only

B - 3 Only

C - 1 and3 Only



D - 3 and 4 only

Q 33 - You can use a checkpoint as in the statement below

Browser("Browser").Page("Page").check CheckPoint("text:=sometext")

A - True

B - False

Q 34 - The changes made in Call to Action, will be reflected in the original action 
fromwherethescriptiscalled where as in Copy Action , the changes made in the script ,will not
effect the original scriptAction

A - True

B - False

Q 35 - How can you remove a stored movie from the test result?

1. Selecting File > Remove Movie from Results.

2. Selecting Tools > Remove Movie from Results.

3. Delete physical movie file from the result location.

4. once recorded you can not remove the movie from test result.

A - 1 2 and 3 only

B - 3 Only

C - 2 and4 Only

D - All 1 2 3 and 4

Q 36 - Which QuickTest operation can not be performed on a virtual object?

1. cannot be used in expert view

2. cannot insert a standard checkpoint

3. cannot insert a image checkpoint

4. cannot use object spy

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - 2 3 and 4

Q 37 - How can you create a .zip file of your test?

1. File > Export Test to zip file



2. File > Save as zip file

3. File > Save Test with sources and select Archive test and resource files in a zip
file check box

4. CTRL+ALT+S

5. you can not create a .zip file of the test.

A - 1 3 and 4 only

B - 4 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 38 - Which of these Add-ins QTP currently supports to work with Extensibility?

1. .Net

2. Visual Basic

3. Delphi

4. Web

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - 1 3 and 4

Q 39 - When you split an action in your test that uses a local repository, Quick Test
makes a copy of the local object repository and if you add objects to one of the split
actions, the new object are added only to the corresponding repository.

A - True

B - False

Q 40 - Which is the best match for the regular expression for deer|dees

1. deer

2. deedess

3. deerees

4. dees

A - 1 2 and 3 only

B - 3 Only

C - 1 and4 Only

D - All 1 2 3 and 4



Q 41 - When you use 'Object' Property of an object. What does it imply?

1. you get a reference to the DOM object

2. you can access the internal methods and properties of the object

3. you can use an object that is not in Object Repository

4. you can access the test object properties of an object from object repository

A - 1 and 2 only

B - 3 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 42 - We can use regular expression for urls in the list of Browsers under Tools >
Options > Web to ignore them during record and replay time.

A - True

B - False

Q 43 - What type of environment variables can be added from Environment view under
Test Settings?

A - Built-in and User-defined

B - Static and Dynamic

C - Only Built-in no User-defined

D - Only Static no Dynamic

Q 44 - Instead of using File > Open Test to open an existing test, what other possible
ways you can use to open an existing test?

1. Select Test from the recent file list in the File menu

2. Select Test from the recent file list in the start page

3. dragging a test from windows explorer

4. Selecting Right click in test editor and select Open Test

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 45 - If you drag-drop a function into your test, UFT removes that function from
Available Keywords pane and inserts a call to the function in the test.

A - True

B - False



Q 46 - How do you synchronize your scripts in QTP ?

1. Sync

2. Exist

3. WaitProperty

4. Visible

A - 1 2 and 3 only

B - 3 Only

C - 1 and3 Only

D - All 1 2 3 and 4

Q 47 - A comment in Expert view can begin with ... so that it can be seen at comments
tab in To Do pane.

1. 'To Do

2. 'to-do

3. 'todo

4. only a single quote ′

A - 1 2 and 3 only

B - 3 Only

C - 1 2 and 3 Only

D - All 1 2 3 and 4

Q 48 - Conditional statements cannot be inserted in Keyword view.

A - True

B - False

Q 49 - Input or Output action parameter name are not case sensitive.

A - True

B - False

Q 50 - Which is the best match for the regular expression for deer |dees

1. deer

2. deedees

3. deerees

4. dees



A - 1 2 and 3 only

B - 2 and 3 Only

C - 1 and 4 Only

D - All 1 2 3 and 4

ANSWER SHEETANSWER SHEET

Question Number Answer Key

1 A

2 C

3 C

4 C

5 D

6 B

7 C

8 B

9 A

10 A

11 A

12 B

13 B

14 C

15 A

16 C

17 B

18 C

19 C

20 B

21 A

22 B

23 C

24 B

25 A

26 D

27 C



28 A

29 A

30 D

31 B

32 D

33 B

34 A

35 C

36 D

37 A

38 D

39 A

40 C

41 A

42 A

43 A

44 D

45 B

46 A

47 C

48 B

49 B

50 B

Processing math: 100%


